Upgrade Ubuntu 6.06->6.10

18.11.2006 – 2:18 pm

Po půl roce používání jsem se rozhodl upgradovat na nejčerstvější verzi této distribuce. Nechal jsem si pár dní, ale nikde se nepsalo, že by přechod byl nějak zvlášť bolestivý. V Ubuntu 6.10 je několik věcí, na které jsem se opravdu hodně těšil, hlavně Vim 7.0, na které jsem si stačil zvyknout ještě když bylo v Debianu Testing jako horká novinka, ale do Ubuntu ještě nedorazilo.

Porušil jsem svoji zásadu, neinstalovat nic nového po 18:00 večer a v osm hodin spustil upgrade. Výsledek předčil veškerá má očekávání. Upgrade skončil naprosto zničnou databází balíků – nevím proč, ale domnívám se, že to bylo proto, že mu najednou někde došla práva – no, už to nezjistím. S polovinou systému aktualizovanou a polovinou zastaralou jsem se rozhodl pro čistou instalaci. Alespoň se mi uklidí systém. Vrazil jsem do počítače čerstvé CD a rebootoval.

Kdyby instalace proběhla hladce, jako probíhala zatím vždy, nebylo by co řešit. Jenže instalační program se rozhodl, že diskový oddíl, na kterém je adresář /boot má souborový systém XFS (na 100% byl ext3). To nebyla sice pravda, ale dokažte mu to. Neukecal jsem ho, a rozhodl se pro instalace staré verze a následný upgrade.

Instalace bez problémů, po upgradu přestala fungovat Xka. Vše jsem vyřešil až druhým pokusem, kdy jsem si tu dokumentaci trochu víc prošel a zaměřil se hlavně na sekci s řešením problémů. Až na pár much už všechno proběhlo v pohodě a já odcházel z práce ve dvě hodiny ráno s pocitem dobře vykonané práce.

Tedy řeknu vám, tohle bych JXD nenabídnul. Škoda té chyby v instalátoru. Že po upgradu nebyl aktivován swap a kromě swapování nefunogovala jaksi hibernace přecházím mlčením. Přece jenom ani Ubuntu není bez chyby. Opět se potvrdilo zlaté pravidlo: “Když to funguje, nevrtej se v tom.”. Příště vám budu vyprávět, jak jsem chtěl na náš mapový server nainstalovat nového mapového klienta. Dávat sem link na starý server je zbytečné – nefunguje :-(

Share Button

Post a Comment